Welcome to Port3101.org : Your BES Connection Mark forums read | View Forum Leaders
Port3101.org : Your BES Connection



Reply
LinkBack (3) Thread Tools Display Modes
BlackBerry Messaging Agent 1 failed to start. Error code 5305
 
  3 links from elsewhere to this Post. Click to view. #1 (permalink)  
Old 02-09-2010, 03:17 AM
BES Activated
 
Join Date: Feb 2010
Location: Ottawa
Posts: 3
Unhappy BlackBerry Messaging Agent 1 failed to start. Error code 5305

Hello!

I am at my wits end as to how to resolve this issue. Everytime my BES server starts up, the BlackBerry Messaging Agent fails to start 10 times and then is shut down by the controller.

The message I get is: BlackBerry Messaging Agent <server name> 1 failed to start. Error code 5305

I have followed and eliminated the 11 steps to take outlined in the Blackberry help technote. Expanded my BESADmin account to full admin rights to everything on my system. Yet no success.

Any help on this issue I would be most grateful for, I am desperate!

Thanks

Greg
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 02-09-2010, 09:02 AM
hdawg's Avatar
Proprietor
 
Join Date: Nov 2008
Posts: 2,257
Blog Entries: 147
Default

So this is a somewhat straightforward issue outlined in http://www.port3101.org/featured-bla...or-5305-a.html.

I'd highly recommend creating a new BES Admin account (assign permissions per: http://www.port3101.org/featured-bla...e-account.html) and then change all the services (while keeping the services stopped)

Login as the new service account make sure you've got a MAPI profile created (http://www.port3101.org/featured-bla...i-profile.html) and then start the services up.

Rather than going through those 13 or so steps again, just start from scratch with a new admin account ... it'll be quicker.
__________________
http://blog.port3101.org/hdawg/
Reply With Quote
  #3 (permalink)  
Old 02-09-2010, 04:39 PM
BES Activated
 
Join Date: Feb 2010
Location: Ottawa
Posts: 3
Unhappy Thanks but still nothing..

Thanks for the help. I created a new account, followed all the steps, but still nothing. After all that I am still getting the same error, except this time with the new account.

After reading many many articles regarding resetting if MAPI profiles, editing registry settings, nothing seems to be working.

The only thing I can add is that this installation of BES is on the Exchange server. I know it is not the preferred way to do it, but it is for a pilot project involving only 5 - 7 users so I felt it would be OK. I researched this and found no documentation saying it couldn't be done.

Is there something that I am missing?? My Exchange server is Exchange 2003 sp2, running on Windows 2003 sp2, server is a member server. BES is 5.0.

Any suggestions or help would be very much appreciated.

Thanks.

Greg
Reply With Quote
  #4 (permalink)  
Old 02-09-2010, 08:02 PM
hdawg's Avatar
Proprietor
 
Join Date: Nov 2008
Posts: 2,257
Blog Entries: 147
Default

Ok, first and foremost BES 5.0 is NOT supported in any way shape or form on the same OS as an Exchange server.

can you copy todays log files to a temp directory, zip them up and email me them ([email protected])? I'll look at em and will post back anything relevant removing anything personally identifiable.
__________________
http://blog.port3101.org/hdawg/
Reply With Quote
  #5 (permalink)  
Old 02-10-2010, 01:11 AM
BES Activated
 
Join Date: Feb 2010
Location: Ottawa
Posts: 3
Smile Resolved!

Hello:

Thanks a million for the simple solution.... get the BES off of the Exchange server. Lesson learned.

I uninstalled the BES, installed on a separate server, everything connected up fine with no issues. I had to wipe my handheld of any old configurations before it would accept an Enterprise Activation from the new server.

So the configuration may not be supported by RIM, I can tell you it doesnt work! Issues experienced.... MAPI, Messaging Agent not starting, possible network name resolution.

All is well now.

Thanks!

GMilne67
Reply With Quote
  #6 (permalink)  
Old 02-10-2010, 01:51 AM
hdawg's Avatar
Proprietor
 
Join Date: Nov 2008
Posts: 2,257
Blog Entries: 147
Default

Excellento! Glad to hear you're up and rolling
__________________
http://blog.port3101.org/hdawg/
Reply With Quote
Reply

Tags
error 5305, messaging agent

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.port3101.org/port-3101-bes-admin-bar-grill/2199-blackberry-messaging-agent-1-failed-start-error-code-5305-a.html
Posted By For Type Date
Blackberry Messaging Agent 1 Failed To Start. Error Code 5305 ... This thread Refback 04-02-2014 06:41 PM
blackberry messaging agent agent 1 failed to start error code 5305 via TwitNit.com This thread Refback 12-31-2013 07:52 AM
Error 5305 Port3101 Org Your Bes Connection This thread Refback 05-17-2010 05:40 AM

Similar Threads
Thread Thread Starter Forum Replies Last Post
KB04772 - Mailbox move repeatedly detected in the BlackBerry Messaging Agent log hdawg Featured BlackBerry KB Articles 0 08-23-2009 09:05 PM
KB00075 - Service failed to start, generating error 5302 hdawg Featured BlackBerry KB Articles 1 08-22-2009 02:33 PM
KB01018 - Service failed to start, generating error 5305 hdawg Featured BlackBerry KB Articles 1 08-20-2009 04:17 PM
KB13518 - Shared Folder Notifications are repeated in the BlackBerry Messaging Agent hdawg Featured BlackBerry KB Articles 0 01-14-2009 07:52 PM
KB15964 - BlackBerry Messaging Agent stops responding when attempting to start a user hdawg Featured BlackBerry KB Articles 0 01-13-2009 10:39 AM


All times are GMT -4. The time now is 03:29 PM.
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.


 

SEO by vBSEO 3.3.2 PL2