Welcome to Port3101.org : Your BES Connection Mark forums read | View Forum Leaders
Port3101.org : Your BES Connection



Reply
LinkBack Thread Tools Display Modes
Best practice for software configuration
 
  #1 (permalink)  
Old 02-18-2009, 07:45 AM
BES Activated
 
Join Date: Feb 2009
Location: ITALY
Posts: 9
Default Best practice for software configuration

I would like to setup a policy to block the installation of 3rd party apps except those assigned by me.
I already created a sw configuration for Google Maps but I cannot install it with "Disallow third party application downloads" set to true.
Anyone can suggest me the correct configuration, please?

Thanks a lot.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 02-18-2009, 09:08 AM
hdawg's Avatar
Proprietor
 
Join Date: Nov 2008
Posts: 2,257
Blog Entries: 147
Default

Follow KB05392 - Control and remove third-party applications using a software configuration to remove applications ... and then add the applications you want to deploy to the software configuration setting their application control policy to either optional or required.
__________________
http://blog.port3101.org/hdawg/
Reply With Quote
  #3 (permalink)  
Old 02-20-2009, 07:35 AM
BES Activated
 
Join Date: Feb 2009
Location: ITALY
Posts: 9
Default

I tried the settings in KB. I setted the root "Application software" to disallowed and then, under this, the application to required. Then I applied the policy to users but with no luck.

Any suggestion?

Thanks a lot.
Reply With Quote
  #4 (permalink)  
Old 02-20-2009, 08:05 AM
hdawg's Avatar
Proprietor
 
Join Date: Nov 2008
Posts: 2,257
Blog Entries: 147
Default

Care to post your POLC log?

If not, can you send me a PM with a link to someplace to download it so I can look at it?

Just to correct your wording ... you changed the software configuration and assigned the configuration to the users (not policy), right?
__________________
http://blog.port3101.org/hdawg/
Reply With Quote
  #5 (permalink)  
Old 02-20-2009, 10:22 AM
BES Activated
 
Join Date: Feb 2009
Location: ITALY
Posts: 9
Default

You're right. I assigned the sw configuration not the plicy.
If you can pm me a valid mail I can send you the log.

Thanks a lot for your support.
Reply With Quote
  #6 (permalink)  
Old 02-20-2009, 10:46 AM
Abe Abe is offline
Super Moderator
 
Join Date: Dec 2008
Location: Germany
Posts: 598
Default

Quote:
Originally Posted by RickyTR View Post
I already created a sw configuration for Google Maps but I cannot install it with "Disallow third party application downloads" set to true.
Anyone can suggest me the correct configuration, please?
As you are going to control application installations through the Application Policy, you must change the setting "Disallow third party application downloads" to "False" in the IT Policy. Else what you are trying, won't work. In the software configuration you need to assign an Application Policy on the "Application Software" level (see red frame) that has "Disposition" set to "Disallowed". This will prevent users from installing applications unless you have white-listed them.
This is how it is configured on my environment:
__________________

Reply With Quote
  #7 (permalink)  
Old 02-20-2009, 11:53 AM
BES Activated
 
Join Date: Feb 2009
Location: ITALY
Posts: 9
Default

Quote:
Originally Posted by Abe View Post
As you are going to control application installations through the Application Policy, you must change the setting "Disallow third party application downloads" to "False" in the IT Policy. Else what you are trying, won't work. In the software configuration you need to assign an Application Policy on the "Application Software" level (see red frame) that has "Disposition" set to "Disallowed".
I have exactly the same config and I setted to default (false) the "Disallow third party application downloads" policy. I applied the policy before assigning the sw configuration.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
KB10644 - "Device State Invalid Error" when trying to push a software configuration hdawg Featured BlackBerry KB Articles 2 08-16-2010 03:56 PM
Software Configuration Issue gibbyoh Port 3101: The BES Admin Bar & Grill 6 05-03-2010 12:28 PM
Software Configuration and ACP design questions (4.1.5) Neo3000 Port 3101: The BES Admin Bar & Grill 0 12-23-2009 05:17 AM
KB15782 - Software configuration push fails due to BlackBerry Policy Service warning hdawg Featured BlackBerry KB Articles 1 05-26-2009 10:36 AM
KB05392 - Control and remove third-party applications using a software configuration hdawg Featured BlackBerry KB Articles 1 02-25-2009 09:01 AM


All times are GMT -4. The time now is 02:42 PM.
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.


 

SEO by vBSEO 3.3.2 PL2