Welcome to Port3101.org : Your BES Connection Mark forums read | View Forum Leaders
Port3101.org : Your BES Connection



Reply
LinkBack Thread Tools Display Modes
BES Collab not working after 5.0 MR2
 
  #1 (permalink)  
Old 08-08-2011, 02:33 PM
BES Activated
 
Join Date: Feb 2009
Posts: 5
Default BES Collab not working after 5.0 MR2

So I installed MR2 whenever it came out, 2 months ago or so? and I cannot get the collab working again. (I upgraded to MR3, no change either)

During the upgrade, nothing was changed in regards to the collab settings, I basically just clicked Next through it.

When I try and sign in to OCS/Lync on my BB I get a message "The server has been shut down"

the BES and OCS is running..

I am on 5.0 MR3 and the latest OCS client on the BB, 2.5.46

Anyone else have this happen? I am seeing this over and over in the event viewer,

<2011-08-08 11:27:35.494 PDT>:[1668]:<BBIM_SERVER_BBIM_1>:<ERROR>:<LAYER = SCM, AdminServiceImpl.run(): java.lang.NullPointerException>
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 08-08-2011, 03:21 PM
BES Addict
 
Join Date: Feb 2009
Location: Toronto
Posts: 69
Default

Q: Are you running BES 5 SP3? if not you have not Lync/Ocs2007 R2 support. IF not install and follow the process in this KB:
Preparing the computer that hosts the BlackBerry Collaboration Service for use with Microsoft Lync Server 2010 - Installation and Configuration Guide - BlackBerry Enterprise Server for Microsoft Exchange - 5.0.3


when you installed SP3 did you click that little button that mentioned somthing about the OCS pool being hardware loadbalanced? If so it could keep Colloaboration services from starting. Stop your instances, connect to them in BAS, disable the setting "Instant messaging server pool is load balanced" is set to "no". In my case with a BES HA pair if load balanced was set to "yes" I could not run both instances at the same time, setting to no fixed - if you call RIM support there is an issue with this "feature"

Hope this helps.

Regards,
Z
Reply With Quote
  #3 (permalink)  
Old 08-08-2011, 03:39 PM
BES Activated
 
Join Date: Feb 2009
Posts: 5
Default

Yes, I'm on 5.0 SP3 (5.0.3 MR3 Bundle 93)

This all worked fine before I installed MR2 a few months back.. I could use OCS/Lync fine..

and during the install, I didn't uncheck/check anything differently. I clicked Next through the collab part because it was working fine.

And that setting is set to no.

Instant messaging server pool is load balanced: No

Here's the BBIM logs themselves, over and over,
<2011-08-04 14:03:27.687 PDT>:[-1]:<BBIM_server_BBIM_1>:<EVENT>:<LAYER = SCM, IM_INFO_MESSAGE = ms - OCS 2007R2>
<2011-08-08 12:52:39.138 PDT>:[1878]:<BBIM_server_BBIM_1>:<ERROR>:<LAYER = SCM, AdminServiceImpl.run(): java.lang.NullPointerException>
<2011-08-08 12:57:39.230 PDT>:[1879]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, BMS: logConfigComplete = true >
<2011-08-08 12:57:39.230 PDT>:[1880]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SRP, Initializing srpServers :[MYSRP[server:3200]]>
<2011-08-08 12:57:39.230 PDT>:[1881]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, Admin. Task- Configuration data>
<2011-08-08 12:57:39.246 PDT>:[1882]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, Admin. Task- Retrieve all server hosts values>
<2011-08-08 12:57:39.261 PDT>:[1883]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, Admin. Task- refresh group>
<2011-08-08 12:57:39.293 PDT>:[1884]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, Admin. Task- PIN-Email mapping rows changed: 0>
<2011-08-08 12:57:39.308 PDT>:[1885]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, Admin. Task- refresh user group membership>
<2011-08-08 12:57:39.324 PDT>:[1886]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, Admin. Task- HTTP Proxy Mappings>
<2011-08-08 12:57:39.355 PDT>:[1887]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, Admin. Task- refresh media management>
<2011-08-08 12:57:39.355 PDT>:[1888]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, existing RSA option = 0 , new RSA option = 0>
<2011-08-08 12:57:39.355 PDT>:[1889]:<BBIM_server_BBIM_1>:<DEBUG>:<LAYER = SCM, Admin. Task Finished>
<2011-08-08 12:58:54.155 PDT>:[1891]:<BBIM_server_BBIM_1>:<EVENT>:<LAYER = SRP, server lost SRP connection with UID MYSRP[server:3200] due to shutdown>

Last edited by sniffs; 08-08-2011 at 04:38 PM.
Reply With Quote
  #4 (permalink)  
Old 08-09-2011, 09:10 AM
BES Addict
 
Join Date: Feb 2009
Location: Toronto
Posts: 69
Default

The only way you can do this PRE BES 5 SP3 is to use an OCS 2007 RTM CWA server (we're running in a similar situation) The only way to do so natively with OCS 2007 R2 is via SP3 and installing all of the OCS components on your BES.

Requirements from the following RIM link

"To access Microsoft Office Communications Server 2007 R2 or Microsoft Lync Server 2010 on your BlackBerry smartphone, you will need:

BlackBerry Client for use with Microsoft Office Communications Server 2007 R2 and Microsoft Lync Server 2010. Download BlackBerry Client for use with Microsoft Office Communications Server 2007 R2 and Microsoft Lync Server 2010
BlackBerry Enterprise Server v5.0 with Service Pack 3. Download BlackBerry Enterprise Server v5.0 with Service Pack 3
BlackBerry Device Software v4.5 or higher"

Before proceeding further I would review ALL of the BES OCS integration/setup documents and make sure you're setup as per RIM's requirements. If you still have probs I would engage RIM support.

Regards,
M@
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitoring Service (non-SNMP not working) lund99 Port 3101: The BES Admin Bar & Grill 0 04-13-2010 03:32 AM
BES 5.0.1 and Exchange Web Services, anyone got it working? mkayz Port 3101: The BES Admin Bar & Grill 3 01-13-2010 09:20 AM
KB12520 - Wireless calendar synchronization is not working in BES v3.6 hdawg Featured BlackBerry KB Articles 0 08-16-2009 06:49 PM
MDS Connection Service Stopped Working bdunnuck Port 3101: The BES Admin Bar & Grill 2 03-31-2009 09:58 PM
Auto Signature not working AUTiger92 Port 3101: The BES Admin Bar & Grill 9 03-10-2009 11:07 AM


All times are GMT -4. The time now is 01:58 PM.
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.


 

SEO by vBSEO 3.3.2 PL2